We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Missing invoices


Alexis.d
05-19-2016, 03:48 PM
Quote Originally Posted by Osmovkiitto@gmail.com
I got an email in french language. It is saying I have to login and check my invoices but there is no new invoice. Please let me know how do you expect me to pay invoice if there are none.
Quote Originally Posted by Evgeniy
Hello, dear Hubic.

I guess my issue is somehow related to this topic. I have registered my hubic.com account on last Friday ( 06/05), and payed 50 EUR for a 10 TB subscription, but at this moment I have only 25 Gb and no invoices in a system.

I can provide any financial information if you need so, but please contact me via e-mail.

Thank you.
Hello,

Your request is being processed by an advisor who has contacted you by email.
Thanks to read it et answer to this one directly.

Have a good day.
Alexis

Evgeniy
05-16-2016, 10:10 AM
Folks, it is not funny.

It is been 10 days since you charge me 50 Euros for nothing, I've got no feedback, no service, nothing.

I really don't like to do it, but this thing is going to reddit.

Evgeniy
05-10-2016, 01:59 PM
Hello, dear Hubic.

I guess my issue is somehow related to this topic. I have registered my hubic.com account on last Friday ( 06/05), and payed 50 EUR for a 10 TB subscription, but at this moment I have only 25 Gb and no invoices in a system.

I can provide any financial information if you need so, but please contact me via e-mail.

Thank you.

Osmovkiitto@gmail.com
05-09-2016, 05:36 PM
I got an email in french language. It is saying I have to login and check my invoices but there is no new invoice. Please let me know how do you expect me to pay invoice if there are none.

xavierh
01-22-2015, 03:03 PM
Hello,

Sorry for the delay and thank you for this feedback.
I'm checking your problem and I will inform you about it as soon as possible.

Have a good day.

sdjohansen
01-16-2015, 09:16 AM
I increased my account to a 100GB plan in April 2014 but only have one invoice on my account to date (January 2015), and I can't see that there has been any charges on my card at any point. I have tried to change my payment method, in case that should be the issue, but are getting an error.
At no point have I received an e-mail regarding payment. Under expiration on my account it states a payment is being processed.
Please advice!