We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Image gallery on OVH VPS using Hubic storage accessed via hubicfuse


david123MM
05-20-2015, 08:12 AM
Hey.. just wanted to say that I tried your backend and so far it was working after some initial struggling with getting the right authentication data. I later found a swift gateway which let me use Duplicity with swift:// ... this was "easier" than using your backend. So I switched.

szavatar
03-27-2015, 06:36 PM
I don't know about your photo gallery application, but I successfully managaed to mount hubic as a share on linux. First I tried with hubicfuse but found it somewhat unstable and having some strange issues. Then I switched to s3ql, which supports swift backend. Hubic is swift with changed authorization process so I used hubic2swift proxy (it's somewhere on this forum also) to make it work. Now I have pydio running in docker and using hubic as storage (via s3ql). It took some time to set it all up, but having my own dropbox-like cloud is worth the time. The only con is that s3ql saves files in hubic in a manner you cannot access them via normal hubic web interface. But you can also set up special swift container just for pydio and save you files there. Works like a charm

maxime
12-28-2014, 02:04 PM
Hi Guys,

I have a very simple server (mail, owncloud, wordpress, etc) running on a VPS 1 from OVH.
It is cheap and runs well for me (less than 5/month for VPS+Domain Name+SSL certificate).

The only thing is that the storage is pretty limited to 10Gio.

My idea is then to have my big files stored on a Hubic account (free for now, 1 for up to 100Gio tomorrow) but accessed and displayed via my VPS web server.

So far, I managed to installed my VPS and it seems that hubicfuse is working fine to mount my hubic account on my VPS in /home/hubic (I can read and write). Thanks for the soft guys !

My issue now (otherwise, I would not be here....) :
- If I go to my simple web gallery with files stored locally, it works
- If I do a symbolic link from my /home/hubic/defaults/Images/mygallery/* to /home/www/MyGalleryApp/Images/ then the gallery app successfully makes a thumbnail in the cache folder, but it eventually fails to display the page.

I tried with various web galleries, same failed result.

It is very strange to me that the app can do a thumbnail but fails to display the pictures right after.

The only error I have from Nginx is "connection stopped as too long".
Another error I had from a web gallery was "files are not present on this server"

However, if I create a folder with just the symlink of pictures in it and let nginx list the files, it works and I can access the files with a nearly immediate result.

Is it because Hubic is very slow for single access of files and so Nginx gives up ? Is it because fuse is really slow to access the files ?
I am doing something not designed for it ?

I tried the combo VPS OVH+HUBIC because it's all the same company and I supposed of good interconnection bandwidth, but, no it seems