Results 1 to 4 of 4

Thread: hubiC for Linux beta 3 is out !

  1. #1
    Team hubiC
    Join Date
    Oct 2013
    Posts
    410

    Lightbulb hubiC for Linux beta 3 is out !

    Hi everyone,

    We are pleased to announce the release of the beta version of the Linux synchronization client.

    It uses the same synchronization engine as the Windows or MacOSX versions and it has been tested by several testers without any obvious problems.

    Technically, we have chosen not to integrate a particular desktop environment but rather to offer a command line interface and a DBus API which enables developers to integrate it into the different desktop environments.

    This configuration will also enable you to easily install the software on servers and NAS, etc…

    For the other uses, don't forget about the hubiC API to develop your own apps.

    Installing the application

    Downloads: http://mir7.ovh.net/ovh-applications...C-Linux/2.1.0/ (always up to date)

    If you are on Debian Wheezy (or higher) or a recent version of Ubuntu, using the .deb packet is advised.

    On Ubuntu, installation of .deb in graphic mode with GDebi is the easiest method. Installation with `dpkg `(Ubuntu or Debian) may require some additional steps:

    Code:
    # dpkg -i hubic.deb
    If you see error messages in connection with unsatisfactory software requirements,
    install them with:

    Code:
    # apt-get install -f
    For distrubutions not based on Debian, a .tar.gz containing a Makefile and installation instructions is also available (you will need to install Mono 2.10+ via your packets manager).

    Once installed, you can log in with the command:

    Code:
     hubic login <email> <folder to synchronize>
    It will start to synchronize your hubiC account and the local folder. You can then see the synchronization status with the 'hubic status' command.

    For the rest, go back to the man.

    Upgrade the application
    Before upgrading, you are encouraged to stop the synchronization process before installing the new package.
    Code:
    $ wget http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/...
    $ hubic stop
    $ sudo dpkg -i hubiC-Linux-XXX-linux.deb
    $ hubic start
    Common problems

    If you try to launch hubiC on a server or via a SSH connection, it is likely that the DBus session bus will not be correctly configured. You will then receive messages such as "Cannot contact daemon, are you sure it is running?".

    You should then manually launch the bus with “dbus-launch”:

    Code:
        $ dbus-launch --sh-syntax
        DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XXXX,guid=XXXXXXX
        DBUS_SESSION_BUS_PID=1234
        $ export DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XXXX,guid=XXXXXXX
        $ hubic login foo@bar.com ~/hubiC
    Or with “dbus-daemon”:

    Code:
        $ dbus-daemon --session --fork --print-address
        unix:abstract=/tmp/dbus-XXXX,guid=XXXXXXX
        $ export DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XXXX,guid=XXXXXXX
        $ hubic login me@foo.com ~/hubiC

    Feedback

    If you experience any issue, please post a thread in Technical Topics with, if possible, with a description of the preceding sequence of operations. If required, we may need to ask you for more details.

    For more general feedback and suggestions, please post a thead in Feature Requests. Even though we don't reply systematically to your messages, please be aware that we have read them and that your feedback is a valuable aid for our developers.

    Thank you all!
    Last edited by Alexis.d; 11-25-2015 at 12:06 PM. Reason: link update

  2. #2
    Team hubiC
    Join Date
    Oct 2013
    Posts
    410
    Hello,

    The new 1.1.13 beta is out ! This release fix several issues with symbolic links and brings some new features:

    • Added: 'publish list' command to list all existing publications (and corresponding DBus method)
    • Improved: uploads/downloads are faster
    • Fixed: non-ASCII characters in symlinks are now accepted
    • Fixed: broken symlinks are ignored
    • Other minor fixed & improvements


    Downloads : see below

    In order to do the upgrade, you you have to stop the syncing process before installing the new version (some adjustments are necessary it you use the .tar.gz archive):

    Code:
    $ wget http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/1.1.13/hubiC-Linux-1.1.13.22-linux.deb
    $ hubic stop
    $ sudo dpkg -i hubiC-Linux-1.1.13.22-linux.deb
    $ hubic start
    Last edited by jdesgats; 03-20-2014 at 10:19 AM.

  3. #3
    Team hubiC
    Join Date
    Oct 2013
    Posts
    410
    Hello,

    A new release is available. It brings all improvements and bugfixes from Windows and MacOSX versions. In addition it fixes the connexion issues of some users and the symlink handling (relative or broken links).

    Downloads: http://mir7.ovh.net/ovh-applications...C-Linux/1.2.4/

    For the update don't forget to stop the background synchronization process before starting the new version:
    Code:
    $ wget http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/1.2.4/hubiC-Linux-1.2.4.35-linux.deb
    $ hubic stop
    $ sudo dpkg -i hubiC-Linux-1.2.4.35-linux.deb
    $ hubic start

  4. #4
    Team hubiC
    Join Date
    Oct 2013
    Posts
    410
    Hello,

    The 2.1.0 update is now available ! It brings the same features as the Windows and OSX versions (notably improved proxy handling and backup-only mode). It also fixes some bugs from version 2.0.


    Downloads: http://mir7.ovh.net/ovh-applications...C-Linux/2.1.0/

    Complete changelog:
    • Added: proxy authentication handling
    • Added: backups can be created inside synchronization
    • Added: synchronization can be disabled
    • Fixed: backup upload could be interrupted by network errors
    • Fixed: error 400 when a backup was deleted and the recreated with same name
    • Fixed: crash when actions on backup were attempted during pause
    • Fixed: the 'kept_versions' switch on backup creation was not handled
    • Fixed: other minor bugs
    • Changed: extra arguments now generates an error (they were silently ignored before)
    • Changed: the libgdiplus library is no longer required to run the program

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •