We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Linux Client can not log in - OAuth error


vcasse
04-22-2014, 08:54 AM
Thanks for your answer

mhurron
04-21-2014, 04:38 PM
Sort of, I fixed it with a big hammer. There was clearly something incorrect in either the /etc/mono/4.5/machine.config or /etc/mono/4.5/settings.map so I simply replaced them with the default machine.config and settings.map.

vcasse
04-16-2014, 09:43 AM
Hi mhurron,

Could you explain your fix with mono for other customers ?

Regards,
Vincent

mhurron
04-16-2014, 12:35 AM
Ok, the problem was my own, there was an issue with my mono installation. However, it became apparent when I ran hubic.exe in monodevelop and could see what it was trying to load.

The option to log exceptions somewhere would be very helpful.

mhurron
04-14-2014, 01:21 PM
Is there a setting or option somewhere I can see the exact error being returned? A simple wireshark session didn't see any traffic to https://api.hubic.com but a web browser, on the same system, can access that address. There is no firewall or other filtering occurring, but I can't do much without seeing more than [Error] https://api.hubic.com/oauth/token/

mhurron
04-11-2014, 08:53 PM
I am unable to login to the service with the linux client with the following error:

/usr/local/bin/hubic login mhurron@saminds.com ~/hubiC
Password:
[Error] https://api.hubic.com/oauth/token/
Command failed: System.InvalidOperationException: Cannot log in.

I am able to login and upload from an Android phone.