We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Graphical user interface for linux


Daeri
03-02-2017, 08:16 AM
Contact help@hubic.com and open a ticket. It's the only way to get an answer (might take a few days but they finally got back to me).

markrich
02-26-2017, 10:08 PM
Ditto here.
Link no longer works.
Where can I download the .deb file?

FranckM
02-23-2017, 10:05 AM
Hi,
I reinstalled Xubuntu on my computer, but the link to download this app doesn't work anymore. Where can go to download it please ?
Thank you

tomdieu
05-13-2016, 11:12 AM
Hello,

I'm using this indicator since the begining without big problem. It's useful!

But today on a fresh new install of Ubuntu 16.4 (it was ok on 16.4 updated from previous instalation), I've this error when trying to lunch the indicator :
/etc/indicator-hubic/hubic.py:5: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
from gi.repository import Gtk, Gio,WebKit, Notify, Gdk,GObject
/etc/indicator-hubic/hubic.py:5: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
from gi.repository import Gtk, Gio,WebKit, Notify, Gdk,GObject
Traceback (most recent call last):
File "/etc/indicator-hubic/hubic.py", line 5, in
from gi.repository import Gtk, Gio,WebKit, Notify, Gdk,GObject
ImportError: cannot import name WebKit
What's the problem?

bartabbas
02-09-2016, 11:40 AM
Quote Originally Posted by linuxcat
I wanted to give this a try, but it does not seem to work.
I'm using Kubuntu 14.04 and here's the error message I got :

Traceback (most recent call last):
File "/etc/indicator-hubic/hubic.py", line 5, in
from gi.repository import Gtk, Gio,WebKit, Notify, Gdk,GObject
ImportError: cannot import name Notify
You have to install gir1.2-notify-0.7 package

Code:
sudo apt-get install  gir1.2-notify-0.7
Best regards,
Bartabbas
Linux Mint KDE 17.3

Point Nemo
12-07-2014, 11:24 AM
Hello,
Do you plan to implement the new backup feature ?

Thank you for this great work.

PS : Is there an applet for Cinnamon ?

linuxcat
11-02-2014, 07:47 AM
I wanted to give this a try, but it does not seem to work.
I'm using Kubuntu 14.04 and here's the error message I got :

Traceback (most recent call last):
File "/etc/indicator-hubic/hubic.py", line 5, in
from gi.repository import Gtk, Gio,WebKit, Notify, Gdk,GObject
ImportError: cannot import name Notify

markrich
11-01-2014, 11:18 AM
I have a couple of bugs presently,

1. Using 0.9 with HubiC version 2.02.48-1 but this GUI client keeps telling me a new version of HubiC is available at 1.2.5.48-1.
How is this possible when I have a much newer release?

2. Having installed this on both desktop and laptop, I sometimes find folders I have moved or removed resync'd to the machine. Where is the fault here? GUI client or HubiC?

Phoenamandre2
08-01-2014, 02:27 PM
New version

Changelog 0.9

Solving issue with XFCE
better window for unity

Phoenamandre2
07-06-2014, 11:18 PM
Yep !

Try this one :
http://ovh.to/ftGbACq

markrich
06-17-2014, 02:38 PM
I like the program a lot but not keen on this new borderless interface on Ubuntu 14.04 with Unity. Can we have the old theme option back?

Phoenamandre2
06-07-2014, 03:23 PM
New version :

new GUI : adapted to gnome 3.10
automatic updates of status
exit function in indicator

Phoenamandre2
05-04-2014, 03:44 PM
The blue version of the UI had some issues with the previous versions of Ubuntu, that's why I made it simpler, but I will to try to improve it !


The status tab create a new virtual mono machine each time it refreshes, so I've to get rid of the hubic command before enabling automatic refresh, but I guess it will be in the next release.
I've also been working on an integration with nautilus. For now, I can right click on a file and share it, as well as copying share link.

fdufnews
05-02-2014, 12:46 PM
Thanks for the upgrade.
Works great on ubuntu 14.04 64bits
2 comments:
- I miss the previous GUI which was more pleasant to the eye (but that's just cosmetic)
- can you make the status window automatically refresh itself to help keeping a eye on uploading progress

Phoenamandre2
05-01-2014, 12:00 AM
New version (once again)

Changelog :

compatibility with Ubuntu 12.04
new GUI : less beautiful, but more portable
solving issues with files publication
solving issues with updates

Phoenamandre2
04-29-2014, 03:37 PM
Thanks !

New version :
- Publish list
- Clean code
- bug resolution
- doesn't depend on hubic anymore (will download it automatically)
- new login pages

edrin17
04-16-2014, 03:28 PM
Hi,
Thanks for the job done. I'm going to test it.

Phoenamandre2
04-10-2014, 09:50 PM
New version 0.4:


NEW VERSION !

- GTK3
- New GUI
- Browser
- Settings

Phoenamandre2
04-03-2014, 10:27 PM
Hi !

Here is something I've written in python + GTK 3 for linux !


https://forums.hubic.com/attachment....8&d=1397160613

http://blog.phoenamandre.fr/files/mi...452844a2ec.png

http://blog.phoenamandre.fr/files/mi...a5529c67a6.png




features :
- login + logout
- tray icon
- notifications
- exclude folders
- settings (upload, download speed, etc)
- pause, resume sync
- browse
- automatic update checking, downloading and installing
- Publish list
- doesn't depend on hubic anymore (will download it automatically)
- new login pages


http://blog.phoenamandre.fr/inc.php?a=3169


New version :
- Publish list
- Clean code
- bug resolution
- doesn't depend on hubic anymore (will download it automatically)
- new login pages



to come :

- no idea