We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Mounting hubic on GNU/Linux with hubicfuse


MadMinion
08-04-2015, 08:35 AM
Hello,

Great job on HUBICFUSE.
But i have one problem, i have 2 installations of HUBICFUSE
SYS1 - Local(VDSL2) / Debian 8.1 / kernel 3.16.0-4-amd64
SYS2 - VPS(Online/100Mbits) / Debian 8.1 / kernel 2.6.32-40-pve

Installation Last Release of HUBICFUSE : OK on BOTH system / Same Settings (2 differents Token)
Mount / Dismount : OK on BOTH system
Retrieving Files/Folders Any size : OK on BOTH system
Sending Files Less 2 GB : OK on BOTH system
Sending Files Over 2 GB :
- OK on SYS1 system (very very long... / Get segments of 1 GB)
- FAIL on SYS2 system (Get Error 'can't extend : operation not authorized')

I've tried to add a line 'segment_above=5368709120' in .hubicfuse but no change occurs.

I opened a ticket to the VPS provider about the kernel version or any limitation he makes,
but i don't really expect a reply from him.

So if antbody have a clue, i'm listening.
I don't know if logs exists for HUBICFUSE.

Thanks

p.s : sorry for my poor english, it's not a natural language !!
(french joke ^^)

gionni
07-27-2015, 07:46 PM
ooooooooooooops my mistakes !!!!!!!
.hubicufse !!!!
i mistake the name file !!!
i see that afeter i post here... i can't remove the post.
scuse me.

thanks for hubicfuse: it's worderful!!!

bye

gionni
07-27-2015, 07:42 PM
i don't understand
why do that????
it's all good configured in .hubicfuse [and i copy it in .cloudfuse to be sure]

:~# hubicfuse -d /mnt/hubic -o noauto_cache,sync_read,allow_other
Unable to determine client_id, client_secret or refresh_token.

These can be set either as mount options or in a file named /root/.hubicfuse

client_id=[App's id]
client_secret=[App's secret]
refresh_token=[Get it running hubic_token]
The following settings are optional:

cache_timeout=[Seconds for directory caching, default 600]
verify_ssl=[False to disable SSL cert verification]
segment_size=[Size to use when creating DLOs, default 1073741824]
segment_above=[File size at which to use segments, defult 2147483648]
storage_url=[Storage URL for other tenant to view container]
container=[Public container to view of tenant specified by storage_url]
temp_dir=[Directory to store temp files]

sebastien180
07-04-2015, 09:04 PM
Hello all,

Everything works fine, i can even create directories with rmake, but I cannot destroy them with rm ! Am i missing something ?

Debian

sunshare
05-13-2015, 04:09 AM
hello, I do everything right but when I try to mount the hubiC I get this err

root@radiocar:/# hubicfuse /mnt/hubic -o noauto_cache,sync_read,allow_other
fuse: device not found, try 'modprobe fuse' first

OS: Debian 7 wheezy

It is much appreciated assistance

agauthier51
02-10-2015, 07:42 PM
Hello,

Just tried the dlo branch.

The builded package is called cloudfuse_0.9-1ubuntu1_amd64.deb (I am using a Kimsufi with Ubuntu 14.04 Server), binary is called hubicfuse, it requires a .cloudfuse parameters file.

Just tried to copy a few 6GB to 10GB .iso files without any problem. Performance looks nice.

Merging this dlo feature with the latest 1.3.1 developments would be just a dream...

Update: when accessing from Hubic web interface the files have right characteristics like size, but from the hubicfuse mount point size is 0.

Arnaud

vulturul
01-23-2015, 03:43 PM
Hello,

I managed to successfully mount my hubic storage via hubicfuse.

What i am trying to do is to achieve a backup destination on hubic.
When i try to rsync a local folder to a hubic mount i get errors and only folders are created, not single file gets transferred,

Code:
root@hubic:~# rsync -auit --progress /root/VltDS/ /mnt/hubic/default/syno/VltDS/
sending incremental file list
rsync: failed to set times on "/mnt/hubic/default/syno/VltDS/.": Function not implemented (38)
and then nothing else happens

Is there someone who can point out what i am missing?

Or if you have any other solution to automate backups (for 10k files / 200 GB) to hubic via linux.

Thank you!

Lucio06
12-27-2014, 07:32 PM
Hi,
following the thread i get the following error; any idea....
!!! CRED_URL result: '{
"error":"insufficient_scope",
"error_description":"scope is insufficient"
}

thanks in advance

Redo the operations, now works, i may have done a mistake first & second time.
Lucio

freeneter
11-04-2014, 05:06 PM
Hey.
Great work, thank you very much.
Can i disable the cache for the filesystem? Because i want to download files / stream files with hubic using my root-server.
But when i try to use ftp to access the /mnt/hubic directory it takes ages to load files with ftp because hubicfuse is caching the files

How to fix this?

michaelsidenius
10-07-2014, 09:05 PM
Hi, I have now implemented the hubicfuse on a Ubuntu 14.4 server. As this is a headless server, I used "rc.local" to automount the hubic filesystem for a dedicated user with:
sudo -u [user] /usr/local/bin/hubicfuse -d /mnt/hubic -o noauto_cache,sync_read,allow_other &> /home/[user]/hubiC/hubicfuse.log &
so didn't have to add password etc to fstab.

With large files I can see transfers to hubiC of 40Mbit/s (I'm on a 100/100 Mbit/s fiber), but with smaller files the performance is horrible! (down to 0.5Mbit/s). It is quiet obvious that the there is a very larger overhead for each file initialization, when looking close on the transfer. Is there ANY way to optimize this? Can any of the cache options be fiddled with (safely)?
Thanks.

hubic
08-05-2014, 02:57 PM
Hello, I have problem, when I open folder on hubic mounted with hubicfuse, all my files from folder will begin automatically download.
It's very slow (because the files are displayed after download) and it causes high network load.
When you view the data through the command line it's ok.

questiontiem
07-27-2014, 06:26 PM
Quote Originally Posted by Turbo
@questiontiem, you don't want to use localhost for the redirect_uri.
Like I said in my post:

I already tried to use my own domain which is using https but that didn't change anything.
Any other ideas?

Turbo
07-27-2014, 09:00 AM
@questiontiem, you don't want to use localhost for the redirect_uri.

questiontiem
07-23-2014, 02:46 PM
Hi,

trying to get hubicfuse to run and I'm running into a problem.

hubicfuse -d output:

!!! HUBIC fails to get Location header
Failed to authenticate.
My ~/.cloudfuse file:

username=mail@example.com
password=7843908034H1234
client_id=api_hubic_JIODOIFJIOIJIO348934
client_secret=jaiosjfdoi784y283032
redirect_uri=http://localhost/
I already tried to use my own domain which is using https but that didn't change anything.

My hubic application settings:

http://i.imgur.com/0wovtDQ.png

Any idea what's wrong there?

Edit: Turns out I'm not using the hubicfuse -d command like I should. I thought it's a standalone debug command but I'll have to use the full command. Now it's starting and after a while:

!!! HUBIC Access token: jioajfoijaoisd1223

!!! HUBIC Token type : Bearer

!!! HUBIC Expire in : 21600

!!! CRED_URL result: '
302 Found

302 Found



nginx/1.4.4



'

!!! HUBIC cannot get json field 'token'

Failed to authenticate.

Turbo
07-18-2014, 09:39 PM
@nanouk, any feedback to share?

yohann.monnier
06-03-2014, 04:52 PM
Hi Gifad, thank you for your answer !

I'll see on this way

gifad
06-03-2014, 02:44 PM
Hello yohann,

sorry I could not help : I'm not make/brew guru, and my process wad blind trial/error, of which I don't remember details...

In the end, I wouldn't recommend to go hubicfuse route on the mac, as the finder is totally unusable, and even at shell level, extensive cacheing leads to unacceptable performance, plus a lot of "unimplemented command" (and the NFC/NFD unicode encoding problem...;;

Working tools (for me) are Cyberduck, and the python swift client (both with HubiC2SwiftGate for authentication)

good luck...

yohann.monnier
06-03-2014, 10:32 AM
Hello Gifad, you said in this post answer that you managed to install hubic fuse on mac osx using home-brew for dependencies installation.

Could you give me your brews ? I tried brew install libxml2-dev libssl-dev libfuse-dev libjson0-dev it said NO ^^

Thank you very much for your help

Quote Originally Posted by gifad
Hello Turbo,

I managed to build, install, and run hubicfuse on MacOSX (with help of OSXFuse and Homebrew for dependencies)

Well, it works (almost), except creating directories :
On MacOSX, the Finder first creates a directory named Untitled, then tries to rename it to the name given by the user, and fails, due to
(from hubicfuse readme)


Using Terminal, the mkdir command works fine, though...

Don't know if this relevant to hubicfuse, or OSXFuse...

Anyway, thanks for the good work !

Turbo
05-18-2014, 09:10 PM
Still waiting eagerly for the feedback

nanouk
05-11-2014, 09:21 PM
Quote Originally Posted by Turbo
I have integrated this work into my hubicfuse now. See branch dlo here: https://github.com/TurboGit/hubicfuse.git

Can you test and report if it is working on your side?
Fantastic! I just saw your post. Sorry I didn't reply before. I just started transferring a large file. Let's see what happens and keep our fingers crossed.
Cheers.

Turbo
05-07-2014, 11:22 AM
Quote Originally Posted by freetomfr
Hi everyone,

I am on Debian Squeeze and i get an error when I try make command :

/tmp/ccklqTvf.o: In function `safe_json_string':
/root/hubicfuse/cloudfsapi.c:520: undefined reference to `json_object_object_get_ex'
/tmp/ccklqTvf.o: In function `cloudfs_connect':
/root/hubicfuse/cloudfsapi.c:669: undefined reference to `json_object_object_get_ex'
collect2: ld returned 1 exit status

Is there someone who can help me?

Thanks
Hum... Looks like you are using an old json library. One solution would be to remove the recent change to avoid deprecated routines.

After cloning the repository to:

$ git checkout -b local 2b8956

Then configure and build from the local branch.

freetomfr
05-05-2014, 05:31 PM
Hi everyone,

I am on Debian Squeeze and i get an error when I try make command :

/tmp/ccklqTvf.o: In function `safe_json_string':
/root/hubicfuse/cloudfsapi.c:520: undefined reference to `json_object_object_get_ex'
/tmp/ccklqTvf.o: In function `cloudfs_connect':
/root/hubicfuse/cloudfsapi.c:669: undefined reference to `json_object_object_get_ex'
collect2: ld returned 1 exit status

Is there someone who can help me?

Thanks

wilo108
05-04-2014, 08:28 PM
Thanks for this project -- the mono-based hubiC client on Linux is awful, and if it wasn't for this project I wouldn't be able to use hubiC at all. Your efforts are appreciated.

Turbo
05-03-2014, 03:29 PM
Quote Originally Posted by nanouk
Hi there,
Do you think it would be possible to add support for large file as in this fork (https://github.com/LabAdvComp/cloudfuse) which I suppose is not natively compatible with HubiC like your code is? Pretty please...
I have integrated this work into my hubicfuse now. See branch dlo here: https://github.com/TurboGit/hubicfuse.git

Can you test and report if it is working on your side?

Turbo
04-28-2014, 04:46 PM
Quote Originally Posted by Schopenhauer
Hello, and thanks for creating this thread for us UBUNTU users.

I tried following the listed steps here:
https://github.com/TurboGit/hubicfuse

After becoming root, I "built" libcurl, fuse, libssl, and libxml2, but once I typed in ./configure, the terminal said:
"no such file or directory."

Where did I go wrong?

ETA: I am using Ubuntu 12.04 LTS, 32-bit OS.
Why did you built from sources all those libraries? They are available from Ubuntu repository as binary packages, no?

Schopenhauer
04-13-2014, 06:18 AM
Hello, and thanks for creating this thread for us UBUNTU users.

I tried following the listed steps here:
https://github.com/TurboGit/hubicfuse

After becoming root, I "built" libcurl, fuse, libssl, and libxml2, but once I typed in ./configure, the terminal said:
"no such file or directory."

Where did I go wrong?

ETA: I am using Ubuntu 12.04 LTS, 32-bit OS.

kheops37
04-04-2014, 02:32 PM
Hello !

In order to be able to mount using /etc/fstab you need to install fuse-utils :

apt-get install fuse-utils

overwise you'll see such error :

mount: wrong fs type, bad option, bad superblock on hubicfuse,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount. helper program)
In some cases useful info is found in syslog - try
dmesg | tail or so


Maybe this could be added to the Readme... it may save some time to others.


Thanks for the good job !

Regards

macomboh
03-24-2014, 06:49 PM
FIXED AND SOLVED!
my .cloudfuse was bad!

the good one would be:

username=email
password=password
client_id=api_hubic_xxxxxxxxx
client_secret=xxxxxxxxxxxxxxxxxxxxxx
redirect_uri=http://localhost/
verify_ssl=True
with no " , no [, ] that was the mistake

the mistake was

macomboh
03-24-2014, 08:10 AM
i made it since i had client_secret and client_ID without or not did i put http://localhost/ or https://othersite.com/ , nothing is done

Turbo
03-23-2014, 01:06 PM
Quote Originally Posted by macomboh
hubicfuse -d /hubic says :
!

the last line disappears if iset verify_ssl =false.
there my .cloudfuse :
Your setting for redirect_uri is wrong as it can't be localhost. You need to create an application from your hubic account.

macomboh
03-22-2014, 11:27 PM
Quote Originally Posted by Turbo
Just in case, the redirect_uri must end with a /
hubicfuse -d /hubic says :
!
!! Authenticating... (client_id = '"api_hubic_BGOmSnFNIOwcsqrEUZwbOrfxzy98anDo"')
* CURLOPT_SSL_VERIFYHOST no longer supports 1 as value
the last line disappears if iset verify_ssl =false.
there my .cloudfuse :
username=lexxxxx@xxx.com
password=xxxxx
client_id="api_hubic_mSnFNIOwcsqrEUZwbOrfxzy98anDo "
client_secret="a6GH2PR7pSoqf5Dn0EtlHvyj5d7qU0paxiH gT2K9WmCgoEYfRYs9EdgZoHfkj"
redirec-uri="http://localhost/"
cache_timeout=20

macomboh
03-22-2014, 10:56 PM
username ok, password ok, but please where i get client_id, client_secret and redirect_uri?
Just start to register your app in your hubic account manager.

You will receive a credential with your client id and your client password

mk89
03-22-2014, 08:30 PM
Hi,
i trying installing hubicfuse - https://github.com/TurboGit/hubicfuse

apt-get ... - its ok
configure, make&install - too ok

but ./cloudfuse...
username ok, password ok, but please where i get client_id, client_secret and redirect_uri?


i try too only this comand without ./cloudfuse:
hubicfuse /mnt/hubic -o username='',password='',noauto_cache,sync_read,allow_other

but this say Failed to authenticate.

Can you help me? What i doing bad?

Thanks

nanouk
03-22-2014, 11:50 AM
Quote Originally Posted by Turbo
Don't know... Maybe but this will require time, and this is a rare resource those days!
I do understand and I love the ease with which I was able to implement your solution . Well, if you ever get round to it, it would be just perfect for many people's needs since then they can just use their HubiC as storage instead of being forced to only synchronize, with all the inherent risks...

Turbo
03-22-2014, 09:07 AM
Quote Originally Posted by Turbo
To have debug you can use : hubicfuse -d

Really don't know what's wrong... Maybe the -d will help!
Just in case, the redirect_uri must end with a /

Turbo
03-22-2014, 09:06 AM
Quote Originally Posted by nanouk
Hi there,
Do you think it would be possible to add support for large file as in this fork (https://github.com/LabAdvComp/cloudfuse) which I suppose is not natively compatible with HubiC like your code is? Pretty please...
Don't know... Maybe but this will require time, and this is a rare resource those days!

Turbo
03-22-2014, 09:05 AM
Quote Originally Posted by macomboh
HI!
last year i used to use hubicfuse with the old way authentication it worked well.
Yesterday I tried the new one but it failed !
I had put the client_id, client_secret and redirect_uri as defined in my own application. with username and password in .cloudfuse but when i tried hubicfuse /mnt/hubic nothing happened (no errors message also)
the client_id, client_secret and redirect_uri are good, there are working in my php's script hosting server.
I use slackware64 14.1.
hubicfuse -h does nothing , is there a debug mode ? how can I a workabout this ?
many thanks indeed for any help.
To have debug you can use : hubicfuse -d

Really don't know what's wrong... Maybe the -d will help!

nanouk
03-21-2014, 10:26 PM
Quote Originally Posted by Turbo
Ok, I've just pushed a new version which support the client_id, client_secret and redirect_uri as defined in user's own application. All seems fine at this point to start using this. Do not hesitate to report issues.
Hi there,
Do you think it would be possible to add support for large file as in this fork (https://github.com/LabAdvComp/cloudfuse) which I suppose is not natively compatible with HubiC like your code is? Pretty please...

macomboh
03-19-2014, 05:48 PM
HI!
last year i used to use hubicfuse with the old way authentication it worked well.
Yesterday I tried the new one but it failed !
I had put the client_id, client_secret and redirect_uri as defined in my own application. with username and password in .cloudfuse but when i tried hubicfuse /mnt/hubic nothing happened (no errors message also)
the client_id, client_secret and redirect_uri are good, there are working in my php's script hosting server.
I use slackware64 14.1.
hubicfuse -h does nothing , is there a debug mode ? how can I a workabout this ?
many thanks indeed for any help.

Inno
02-26-2014, 11:47 AM
Thanx,
I was testing mounting fstab with "sudo mount -a" and noauto parameter, but "mount -a" do not mount fs with noauto parameter...
Now, I am testing with:

hubicfuse /mnt/hubic fuse username=xxx,password=xxx,client_id=xxx,client_sec ret=xxx,redirect_uri=http://localhost/,_netdev,noauto,noauto_cache,sync_read,user,allow_ other 0 0

allow_other parameter is to grant access if mounted by root
user parameter is to allow mounting by users (user can mount using Nautilus)
setting user and allow_other parameters need to change /etc/fuse.conf to enable user_allow_other

Turbo
02-25-2014, 08:29 PM
Quote Originally Posted by Inno
Hi,

I installed and started testing on ubuntu. Then try on Debian.
You can write an example for fstab mount?
We need to enter client_id, client_secret and redirect_uri?
For fstab info see: https://github.com/TurboGit/hubicfuse

Note that it is very important to have the noauto otherwise your computer may not boot. I had this problem. Beware!

Inno
02-25-2014, 07:11 PM
Hi,

I installed and started testing on ubuntu. Then try on Debian.
You can write an example for fstab mount?
We need to enter client_id, client_secret and redirect_uri?

Turbo
02-19-2014, 09:25 AM
Quote Originally Posted by gifad
Hello Turbo,

I managed to build, install, and run hubicfuse on MacOSX (with help of OSXFuse and Homebrew for dependencies)

Well, it works (almost), except creating directories :
On MacOSX, the Finder first creates a directory named Untitled, then tries to rename it to the name given by the user, and fails, due to
(from hubicfuse readme)


Using Terminal, the mkdir command works fine, though...

Don't know if this relevant to hubicfuse, or OSXFuse...

Anyway, thanks for the good work !
Probably an issue with the renaming. I'm using only a script to copy files on my hubic mount on GNU/Linux so I've never hit this issue.

gifad
02-18-2014, 11:11 PM
Hello Turbo,

I managed to build, install, and run hubicfuse on MacOSX (with help of OSXFuse and Homebrew for dependencies)

Well, it works (almost), except creating directories :
On MacOSX, the Finder first creates a directory named Untitled, then tries to rename it to the name given by the user, and fails, due to
(from hubicfuse readme)
* rename() doesn't work on directories (and probably never will).
Using Terminal, the mkdir command works fine, though...

Don't know if this relevant to hubicfuse, or OSXFuse...

Anyway, thanks for the good work !

Turbo
02-18-2014, 09:33 PM
You need to create an application on your Hubic account. The redirection URL is any URL in https with a trailing /, it does not matters if the URL is pointing to some running server or not. In my case it is not, and I can mount without problem.

tjeh
02-18-2014, 08:11 PM
Hi i just stumbled across hubic and your fuse implementation.

I successfully build the hubicfuse with my linux machine. Could you give any hints as to how to install/configure the "redirection" url?

Regards,

tjeh

Turbo
02-16-2014, 06:58 PM
You're welcome

daouda
02-16-2014, 10:40 AM
Hello,

I just had one missing dependency on debian wheezy : libjson0-dev

Otherwise, seems to work very well. Now I can do real one-way backups, not synchronized. Thank you !

Turbo
02-15-2014, 08:20 PM
Ok, I've just pushed a new version which support the client_id, client_secret and redirect_uri as defined in user's own application. All seems fine at this point to start using this. Do not hesitate to report issues.

Turbo
02-15-2014, 12:46 PM
I have upgraded hubic fuse project to the new Hubic API. I have been able to mount my Hubic account, the code is here:

https://github.com/TurboGit/hubicfuse

Comments welcomed.